Wordfence Firewall blocked a background request to WordPress

Q: Every time I drag the Recent Posts Extended widget into the footer, I get a message from Wordfence Firewall:

Wordfence Firewall blocked a background request to WordPress for the URL /wp-admin/admin-ajax.php. If this occurred as a result of an intentional action, you may consider whitelisting the request to allow it in the future.

Whitelist this action    Dismiss

A: Select Whitelist this action and you're good to go. If you are still having issues, follow these steps:

  • Go to Plugins in your WordPress Dashboard and deactivate Wordfence Security for a few minutes. 

  • Then, go to the Widgets page, drag the Recent Posts Extended widget into the footers and click Save.

  • After that, go back to Plugins and reactivate Wordfence Security.